Kali Linux 2017.1 安装vmware 报错

vmware

0x00 阳光普照

官网下载地址:VMware-Workstation for linux

Key:VF5XA-FNDDJ-085GZ-4NXZ9-N20E6

0x01 问题

安装了Kali Linux 2017.1, 熟悉的老司机姿势安装Vmware

安装内核头文件

1
2
3
apt-get update && apt-get dist-upgrade
apt-get install linux-headers-$(uname -r)

然后竟然翻车了

1
2
3
4
5
6
7
8
[email protected]:~# apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-4.9.0-kali3-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-kali3-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-kali3-amd64'

搜索内核头安装包apt search linux-headers

1
2
linux-headers-4.9.0-kali4-all-amd64/kali-rolling 4.9.30-2kali1 amd64
All header files for Linux 4.9 (meta-package)

只有kali4没kali3

0x02 解决

1
2
3
4
5
6
7
8
9
10
11
apt-get install linux-headers-amd64
#执行后重启机器
reboot
[email protected]:~# uname -r
# 4.9.0-kali4-amd64
apt-get install linux-headers-$(uname -r)

OK 解决